メインコンテンツまでスキップ

ダッシュボードの視覚化

視覚化ウィジェットは、ダッシュボードのデータセットをグラフとしてレンダリングします。グラフ タイプを選択し、軸とエンコーディングを定義し、軸の値とラベルをフォーマットし、ウィジェットのタイトルと説明をリッチテキストでフォーマットできます。

チャートを作成して設定する​

視覚化ウィジェットをキャンバスに追加すると、画面の右側に 視覚化構成 パネルが表示されます。デフォルトでは、 [データ] タブにリストされている最初のデータセットが選択され、デフォルトの視覚化タイプは 棒グラフ になります。

空白の視覚化ウィジェットと視覚化構成パネル。

チャートを作成するには、次のステップを使用します。

  1. データセットを選択する: データセット ドロップダウンを使用して、ビジュアライゼーションのデータセットを選択します。
  2. フィルターの追加 (オプション): 視覚化に静的フィルターまたはパラメーターを適用するには、 [フィルターの表示] をクリックします。任意のフィールドでフィルタリングできます。データセットに問題が含まれている場合は、それを適用するオプションも表示されます。
  3. 視覚化タイプを選択します。 「視覚化」 ドロップダウン メニューから視覚化タイプを選択します。使用可能な視覚化タイプとその構成の詳細については、 AI/BI dashboard視覚化タイプ」を参照してください。
  4. x 軸と y 軸のフィールドを定義する: データセットを選択した後、x 軸と y 軸に表示するフィールドを選択します。フィールドを目的の位置にドラッグして並べ替えることができます。グラフ ラベルの場合、表示名フィールドを使用して軸ラベルの名前を変更できます。
注記

Genie コードを使用してグラフを生成する場合、データセットと視覚化の選択はリクエストに基づいて自動的に調整されます。AI 支援による視覚化を作成するためのステップバイステップのガイドについては、 「ダッシュボード作成に Genie Code を使用する」を参照してください。

視覚化クエリを表示する​

ドラフトモードでは、視覚化ウィジェットが実行する完全なSQLクエリ(現在適用されているパラメーターやフィルターを含む)を表示できます。これは、データの正確性を検証したり、予期しない結果のトラブルシューティングを行ったり、ダッシュボードのフィルターやパラメーターが基となるクエリにどのように影響するかを理解したりするのに役立ちます。

  1. クリックケバブメニューアイコン。視覚化ウィジェット上のケバブメニュー。
  2. 「視覚化クエリを表示」 をクリックします。

ビジュアライゼーションウィジェットのSQLクエリーを表示するモーダルが表示されます。このクエリーはウィジェット固有のものであり、そのビジュアライゼーションのレンダリングに必要なデータのみを返します。これは完全なデータセットのクエリーとは異なります。クエリーには、適用されたすべてのフィルターの現在の状態が反映されます。基になるデータセットでパラメーターを使用している場合、パラメーター値はクエリーに代入されません。その代わりに、参照用にモーダルの上部に表示されます。

ウィジェットのタイトルと説明の書式設定​

ウィジェットのタイトルと説明はリッチテキストをサポートしています。ウィジェットヘッダーでは、重要な用語の強調、定義へのLink、またはフィルターの現在の値の表示を行うことができます。

ウィジェットのタイトルまたは説明をクリックすると、編集を起動できます。ウィジェットの上に書式設定ツールバーが表示され、両方のフィールドで @ と入力してフィルターまたはフィールドを参照するように求められます。

編集モードの棒グラフウィジェット。上部にリッチテキスト形式のツールバーがあり、タイトルと説明のフィールドにプレースホルダーテキストが表示されています

テキストの書式設定​

書式設定ツールバーを使用して、タイトルや説明を次のようにスタイル設定します。

  • テキストのスタイル設定 : ブロックのスタイル、フォント、フォントの太さ、フォントサイズ、テキストの色を調整し、下線を適用します。フォントのドロップダウンメニューから、20種類のオープンソースフォントを選択します。
  • 配置 :テキストを左揃え、中央揃え、または右揃えにします。
  • Linkの挿入 :Linkアイコンをクリックして、Linkエディターを開きます。URL と表示する Link テキストを入力してください。
  • テーブルの挿入 : テーブルアイコンをクリックしてテーブルを追加します。
  • 書式設定のクリア : 選択したテキストからすべての書式設定を削除します。

マークダウン構文を直接入力することもできます。例えば、**Revenue**と入力すると、テキストが太字として書式設定されます。ベースのマークダウンを編集するには、ケバブメニューアイコン。 ケバブメニューをクリックし、 [マークダウンを表示] を選択します。基本的なマークダウン構文の詳細については、マークダウンガイドを参照してください。

書式設定は、フィルターおよびフィールドの参照にも適用されます。参照は、周囲のテキストの書式を引き継ぎます。ウィジェットヘッダーで参照値を際立たせるために、太字、色付け、またはサイズ変更を行うことができます。たとえば、 Total revenue: とその横にあるフィールド参照を同時に太字にすると、ビューアには解決された値が太字で表示されます。削除されたフィルターまたはフィールドへの参照は、 (削除済み) インジケーターの色を保持しますが、太字や斜体などの他の書式設定は引き続き適用されます。

テキストウィジェットは同じエディタを使用します。テキストウィジェットを参照してください。

注記

ウィジェットのタイトルや説明に画像を挿入することはできません。テキストウィジェットでは画像がサポートされています。画像パスとURLを参照してください。

フィルターまたはフィールドを参照する​

ウィジェットのタイトルや説明にフィルターやフィールドを参照させることができます。これにより、ヘッダーがダッシュボードのフィルターやクロスフィルターの選択に応答するようになります。フィルター参照には、閲覧者の現在の選択が反映されます。フィールド参照には、ライブの集計メトリクスが表示されます。

例えば:

  • フィルターを参照するには、「Sales for @region」と入力し、「region」フィルターを選択します。閲覧者が [West] を選択すると、タイトルは Sales for West になり、選択内容が変更されると更新されます。
  • フィールドを参照するには、Total revenue: @ と入力して revenue フィールドを選択します。参照は Total revenue: $1.2M などの集計に解決され、閲覧者がフィルターまたはクロスフィルターを適用したときに更新されます。

参照を追加するには:

  1. ウィジェットのタイトルまたは説明をクリックして編集を開始します。
  2. @ と入力して、利用可能なフィルターとフィールドのリストを開きます。
  3. 入力を続けてリストを絞り込みます。
  4. フィルターまたはフィールドを選択します。

ウィジェットタイトルに表示される @ タイプアヘッド。データセットとそのフィールドをデータ型アイコンとともに一覧表示します

フィールドを選択すると、フィールドのタイプに基づいてdefaultの集計が適用されます。フィールド、集計、または書式設定を変更するには、参照をクリックして構成ポップオーバーを開きます:

  • Value tabで、フィールドを変更するか、別の集計関数を選択します。利用可能な関数はフィールドのタイプによって異なります。数値フィールドの場合、SUM、AVG、MEDIAN、MIN、MAX、COUNT、COUNT DISTINCT、VAR、STD、PERCENTILE、FIRST、LASTが含まれます。
  • Format tabで、数値の型、略称、精度、グループ区切り記号、負数記号など、数値または日付の書式を設定します。数値の書式設定の詳細については、数値形式の書式設定を参照してください。The Format tabはテキストフィールドには表示されません。

フィールドセレクターと集計オプションを示す、[Value] tab のフィールド参照構成ポップオーバー

フィールド参照は、ウィジェット固有のデータセットだけでなく、ダッシュボード上の任意のデータセットをターゲットにすることができ、1つのタイトルまたは説明で複数のフィールドを参照できます。

参照には次の制限があります:

  • フィルターとパラメーターのウィジェットは、他のフィルターを参照できません。これにより、フィルター間の循環参照が防止されます。
  • フィールド参照は、ビジュアライゼーションウィジェットのタイトルと説明でのみ使用できます。これらは、フィルターやパラメーターウィジェットなどのコントロールウィジェットでは使用できません。
  • フィールド参照のターゲットとなるのは、単一のデータセットからのフィールドです。クロスデータセットのメジャーはサポートされていません。セマンティックモデルを使用するダッシュボードがサポートされています。
  • 参照されているフィールドの名前が変更されたり削除された場合、参照には (removed) が表示されます。

テキストウィジェットでのパラメーターの参照については、テキストウィジェットでのパラメーターの使用を参照してください。

書式設定が適用されない場合​

以下の場所では、書式設定が削除され、タイトルがプレーンテキストとして表示されます。以下の場所に表示されるタイトルでは、意味を伝えるために書式設定に依存しないでください:

  • チャットウィンドウ、Genie Agent、Genie One など、Genie が表示するチャートのタイトルとビジュアライゼーションの参照
  • ダッシュボードエディター内のウィジェットリスト
  • ダッシュボードのサブスクリプションの添付ファイル
  • フィルターのツールチップ
  • The file name of a download data export

その他の書式設定の動作​

書式設定は、以下の場合にも異なる動作をします。

ウィジェットをimageとしてdownloadすると、テキストのスタイルが保持されます。

ウィジェットの高さが1行のみでタイトルが表示されている場合、説明はタイトルの横ではなく、情報アイコンの背後にあるツールチップに表示されます。説明をインラインで表示するには、ウィジェットの高さを大きくするか、タイトルを非表示にします。

グラフの書式を適用する​

グラフには、軸、色、ラベル、ツールヒントのカスタマイズ可能な書式設定オプションが含まれています。書式設定オプションは、グラフの種類とデータセットの値によって異なります。

次のスクリーンショットは、x 軸と y 軸の書式設定に使用されるケバブ メニューを示しています。

x 軸と y 軸のフォーマットに使用するケバブ メニューを強調表示したスクリーンショット。

軸の書式設定​

x軸またはy軸の書式を設定するには、ケバブメニューアイコン。視覚化編集パネルのそれぞれの X 軸 または Y 軸 セクションにあるケバブ メニュー。

次の設定を構成します。

  • 軸タイトルを表示: デフォルトで有効になっています。カスタムタイトルを入力するか、チェックボックスをオフにして軸タイトルを非表示にします。
  • 軸の値を表示: デフォルトで有効になっています。軸の値を非表示にするには、チェックボックスをオフにします。

表示されるデータのタイプに応じて、追加のコントロールが表示されます。

数値データの場合:

  • 軸の範囲 :軸の範囲の決定方法を選択します。

    • Default :自動範囲を使用します。ファセットチャートでは、直接比較できるようにすべてのサブチャートが1つの範囲を共有します。
    • [ファセットごと] :ファセットグラフで、各サブチャート固有のデータに合わせて軸のスケールを調整します。ファセット化されていないグラフの場合、これは効果がありません。ファセット化を参照してください。
    • カスタム :軸の固定された 最小値 と 最大値 を設定します。
  • 軸を反転: 軸の値を降順で表示するには、 「軸を反転」 を選択します。

  • スケール関数: 線形 または 対数 (対称) を選択します。

  • 追加の書式設定オプションを表示するには、 [書式] をクリックします。 「自動」 を選択すると、グラフのフォーマットが自動的に行われ、デフォルトで選択されます。追加の書式設定オプションを表示するには、 「カスタム」 をクリックします。「数値の書式設定」を参照してください。

カテゴリデータの場合:

  • ラベル角度: ラベルを適用する角度を選択します。デフォルトでは 自動 が選択されています。
  • 並べ替え: 軸上のカテゴリ値の順序を選択します。
    • アルファベット順 : カテゴリ名をアルファベット順に並べ替えます

    • フィールド別 : メジャー フィールド値を昇順または降順で並べ替えます。並べ替えの方向を選択したら、使用するフィールドを選択します。

      • Y軸 : Y軸に表示されるメジャーフィールドで並べ替えます
      • フィールド : チャートに表示されていない場合でも、データセット内の他のメジャー フィールドで並べ替えます。ドロップダウンからフィールドを選択し、集計 (SUM、MIN、MAX、または COUNT) を選択します。これは、ビジュアライゼーションを乱雑にせずにコンテキストを提供するメトリクスによってカテゴリーを順序付けするのに役立ちます。
    • カスタム : 値を特定の順序で並べます。値の上にマウスを移動し、グラブハンドルを使用して値を所定の位置にドラッグします。

ラベルの天使と並べ替えのオプションが x 軸に適用されたグラフ。

注記

リストされているオプションのいずれかが使用できない場合は、選択したグラフの種類に適用できません。

数値の書式設定​

軸の目盛りラベル、データ ラベル、ツールヒントの数値を書式設定できます。書式設定オプションにアクセスするには:

  1. クリックケバブメニューアイコン。チャート設定パネルの X 軸 または Y 軸 の横にあるケバブ メニュー。
  2. [フォーマット] をクリックし、次のオプションから選択します。
  • タイプ: なし、通貨 ( $ )、パーセンテージ ( % )
  • 略語: なし、コンパクト、科学的
  • 小数点以下の桁数: 最大、正確、すべて、またはカスタムの桁数
  • グループ区切り文字: オプションで、カンマまたはその他の区切り文字を含めます。
  • 負の符号: 負の数の表示方法を選択します。標準的なマイナス記号を使用する場合は、 -123.45 (デフォルト)を選択してください。会計スタイルの括弧を使用する場合は、 (123.45) を選択してください。
注記

さまざまな通貨形式が利用可能です。 通貨 を選択した後、ドロップダウン メニューから希望のオプションを選択します。

グラフ要素をカスタマイズする​

グラフの凡例、色、マーカーの形状、線のパターン、ツールチップ、値のラベルをフォーマットできます。

チャートの色​

グラフの色を変更するには:

  1. グラフ内の色をクリックすると、カラーピッカーが開きます。
  2. 正確な色を指定するには、HEX 値または RGB 値を入力します。
  3. クリックケバブメニューアイコン。 色 セクションのケバブ メニューを使用して、すべての色の不透明度を調整します。

ウィジェット間での色の一貫性​

チャートがカテゴリフィールドで色分けされる場合、ダッシュボードはダッシュボード上のすべてのウィジェットで同じ値に対して自動的に同じ色を使用します。例えば、あるチャートで Australia が特定の色で表示されている場合、同じフィールドで色分けされているダッシュボード上の他のすべてのチャートでも、Australia はその色で表示されます。

ウィジェットがカラーを共有するのは、同じデータセットの同じフィールドで色分けされている場合のみです。異なるデータセットの同じ名前のフィールドは、独自のカラーを保持します。色の整合性は単一のダッシュボードに限定されるため、色がダッシュボード間で引き継がれることはありません。これは フィールドによる色別 に適用され、 シリーズによる色別 には適用されません。

値に特定の色を使用するには、カラーピッカーで設定します。手動で設定した色は、自動割り当てよりも優先されます。

ダッシュボード全体で値の自動色を設定するには(一度に1つのウィジェットではなく)、ダッシュボードのテーマ設定でカラーマッピングを使用します。ワークスペースのテーマを作成または更新するを参照してください。

カラーパレットtabの「カラーマッピング」セクション。値の名前がカラー見本にマッピングされている様子を示しています。

凡例​

クリックケバブメニューアイコン。 色 セクションのケバブ メニューをクリックすると、グラフの凡例の表示、タイトル、または位置を変更するためのオプションが表示されます。次のオプションが利用可能です。

  • 凡例を表示: チェックボックスを使用して凡例を表示または非表示にします。
  • 凡例タイトルを表示: チェックボックスを使用して、凡例タイトルを表示または非表示にします。タイトルが表示されている場合は、列名であるデフォルト値を上書きするように入力できます。
  • 凡例の位置: ドロップダウンを使用して、視覚化ウィジェット内の凡例の配置を調整します。凡例は、視覚化の上部、下部、左側、または右側に配置できます。

ツールチップ​

ツールチップには、ポインターの下のデータの正確な測定値が表示されます。デフォルトでは、x 軸、y 軸、および色/グループ化フィールドの値が表示されます。ツールチップにフィールドを追加するには:

  1. プラスアイコン。ビジュアライゼーションエディタの ツールヒント セクションにある プラスアイコンをクリックします。
  2. ドロップダウンを使用して追加のフィールドを選択するか、テキスト入力ボックスを使用して名前で検索します。
注記

視覚化エディターに ツールチップ セクションが存在しない場合は、そのチャートの種類はツールチップのカスタマイズをサポートしていません。

値ラベル​

トグルを使用してデータ ラベルのオン/オフを切り替えます。有効にすると、ラベルの表示方法を選択できます。

  • 自動 : Y軸の値をラベルとして表示します。
  • フィールド : ラベルとして表示する特定のフィールドを選択します。変換 (SUM や AVG など) を適用し、選択したフィールドの書式設定オプションを選択できます。

NULL 値はグラフ上のラベルとして表示されません。条件付きロジックを使用して、ラベルを選択的に表示できます。

次のクエリは、特定のデータポイントに対してのみラベルが表示されるデータセットを作成します。

SQL
SELECT
*,
CASE
WHEN pickup_zip = 10009 THEN fare_amount
ELSE NULL
END AS custom_label
FROM
samples.nyctaxi.trips

値ラベル フィールドとしてcustom_labelを使用すると、 pickup_zip = 10009のデータポイントのみにfare_amountを示すラベルが表示されます。 Null 値を持つ他のすべてのデータポイントは、ラベルなしでチャートに表示されます。

値ラベルが付いた 1 本の線のみを表示する視覚化。

サイズ設定​

サイズ 設定は、折れ線グラフ、散布図、バブル チャート、ポイント マップの視覚的な寸法を制御します。使用方法はグラフの種類によって異なります。

折れ線グラフ:

  • サイズ 領域にシリーズが指定されていない場合、スライダーはすべての線の太さを均一に変更します。
  • 「サイズ」 領域でシリーズを指定した場合、シリーズごとに異なる厚さの値を設定できます。

散布図とバブルチャート:

  • メトリックに基づいてポイント マーカーのサイズを変更するには、 サイズ 設定にフィールドを追加します。
  • サイズがデータ フィールドに基づいている場合、チャートはバブル チャートになり、各ポイントのサイズはメトリック値を反映するようになります。

ポイント マップ: サイズ 設定を使用して、定量フィールドに基づいてマップ マーカーのサイズを変更し、さまざまな地理的な場所の大きさを表示します。

マーカー​

折れ線グラフでは、 マーカー 設定によって線上の各データポイントにマーカーが描画されます。マーカースウォッチをクリックしてすべてのポイントに同じ形状を設定するか、プラスアイコン。 マーカー セクションのプラスアイコンをクリックして、系列ごとに異なるマーカー形状を設定します。使用できる形状には、円、正方形、ひし形、十字、X、星、三角形があります。

Marker 設定は、折れ線グラフにのみ適用されます。散布図では、代わりに Shape 設定を使用します。

形状​

散布図では、 形状 設定によって各ポイントの形状を制御します。形状スウォッチをクリックしてすべてのポイントに同じ形状を設定するか、プラスアイコン。 形状 セクションのプラスアイコンをクリックして、カテゴリーフィールドごとに異なる形状を設定します。使用できる形状には、円、正方形、ひし形、十字、X、星、三角形があります。

形状 設定は、散布図にのみ適用されます。折れ線グラフでは、代わりに マーカー 設定を使用します。

パターン​

折れ線グラフおよびコンボチャートでは、 [Pattern] 設定によって各線のダッシュスタイルを制御します。プラスアイコン。 [Pattern] セクションにあるプラスアイコン をクリックしてカテゴリフィールドを選択すると、1つの系列には実線、別の系列には破線を使用するなど、各線のダッシュスタイルを変更できます。利用可能なスタイルは、solid、dashed、dottedです。

コンボグラフや複数のメジャーをプロットするグラフでは、 マーカー 設定と 形状 設定を使用できません。これらのグラフでは、線系列を区別するために パターン 設定を使用します。

グリッドライン​

グラフでは、読みやすさを向上させるためにグリッド線のオンとオフを切り替えることができます。グリッド線は、サポートされているチャート タイプにデフォルトで表示され、軸の値に合わせた視覚的な参照線を提供することで、閲覧者がデータポイントを解釈するのに役立ちます。

グリッドラインを切り替えるには:

  1. 視覚化構成パネルで、グリッド線オプションを見つけます。
  2. トグルを使用して、グラフのグリッド線を表示または非表示にします。

グリッド線は、カスタム背景色と軸の書式設定に基づいて自動的に調整されます。

注釈​

アノテーションは、しきい値、ターゲット、またはベンチマークを追跡するためにチャートに追加できる水平または垂直の参照線です。アノテーションラインは、固定された定数値にすることも、平均や特定の測定値など、データによって駆動されるようにすることもできます。

アノテーションラインのあるチャート。

次のグラフ タイプは注釈をサポートしています。

  • 定数とカスタム: エリア、棒、ボックス、複合、ヒートマップ、ヒストグラム、折れ線、散布図、ウォーターフォール
  • 集計 :面グラフ、棒グラフ、箱ひげ図、折れ線グラフ、散布図のみ。100%スタックレイアウトのグラフでは利用できません。

注釈を追加するには:

  1. 視覚化構成パネルで、 注釈 セクションを見つけます。

  2. 新しい注釈を追加するには、プラスアイコン。 プラスアイコンをクリックします。

  3. 線の方向を選択します:

    • 水平 :指定されたY軸の値でX軸に平行な線を描画します。
    • 垂直 :指定されたX軸の値に、Y軸に平行な線を描画します。
  4. アノテーションタイプを選択し、構成してください。

    • 定数 :線が表示される固定値を入力してください。
    • Yを集計 (横)/ Xを集計 (縦):集計方法( Avg 、 Min 、または Max )を選択します。線の位置は、基になるチャート データの集計として計算されます。
    • カスタム :データセットからフィールドまたはメジャーを選択します。線の位置は別のクエリで計算されます。集計されたフィールドを選択すると、1本の線が描画されます。集計されていないフィールドを選択すると、返された行ごとに1本の線が描画されます。
  5. (オプション)ラベルを入力します。ラベルは、グラフ上の線の横に表示されます。

  6. (オプション) カラーピッカーをクリックして線の色をカスタマイズします。

1 つのグラフに複数の注釈を追加して、さまざまなしきい値または参照ポイントを追跡できます。

予測を生成する​

AI Forecast (パブリック プレビュー) を使用して、予測予測を折れ線グラフに適用し、将来の傾向とパターンを視覚化します。折れ線グラフでは、x 軸に一時的な日付フィールド、y 軸に単一の数値フィールドが必要です。

AI 予測を含むグラフを作成するには:

  • 折れ線グラフを選択した状態で、プラスアイコン。 予測 の右側にあるプラスアイコン。
  • 表示されるダイアログで AI予測でクローンを作成 をクリックします。予測が適用された新しい折れ線グラフが作成されます。

予測を生成する関数の詳細については、 ai_forecast関数を参照してください。

折れ線グラフの予測が生成されます

ファセット​

Facet エンコーディングにディメンションを追加して、そのディメンション内のすべての値に対してチャートまたはカウンターを繰り返します(トレリスチャートやスモールマルチプルチャートとも呼ばれます)。defaultでは、サブチャートは各連続軸で1つの範囲を共有するため、直接比較できます。ファセッティングを追加するには:

  1. プラスアイコン。ビジュアライゼーションエディタの ファセット セクションにある プラスアイコンをクリックします。
  2. ドロップダウン メニューを使用してディメンション フィールドを選択します。

の中でケバブメニューアイコン。 ファセット の横にあるケバブ メニューでは、基になるグリッドの行と列の数をオプションで設定できます。グリッドから溢れた値はグラフ上でスクロールします。

数値軸を共有の範囲ではなく各サブチャート固有のデータに合わせてスケーリングするには、 軸の範囲 を ファセットごと に設定します。分類別ファセット軸では、各サブチャート固有のカテゴリが常に表示されます。「軸の形式設定」を参照してください。

カウンターをファセット化することもできます。カウンターに ファセット ディメンションを追加すると、同じグリッド内にディメンション値ごとに1つのカウンタータイルがレンダリングされます。カウンターには軸がないため、 ファセットごと を含む軸の範囲オプションは適用されません。カウンターにスパークラインが表示されている場合、すべてのタイルが1つのドメインを共有するため、タイル間でスパークラインの傾向を比較できます。

製品別に4つのサブチャートにファセットされ、それぞれ時間経過に伴うレコードの毎日の件数を示す棒グラフ

構成値 : この例では、次の値が設定されています。

  • データセット: samples.bakehouse.sales_transactions

  • X軸:

    • フィールド: dateTime
    • 変換: Daily
  • Y軸:

    • フィールド: COUNT(*)
  • ファセット:

    • フィールド: product

その他の視覚化タイプ​

テーブル視覚化の操作の詳細については、 「テーブルとピボット テーブルの視覚化」を参照してください。

マップ視覚化の操作の詳細については、 「マップ視覚化」を参照してください。