Pular para o conteúdo principal

Visualizações do painel de controle

Os widgets de visualização renderizam os datasets do seu dashboard como gráficos. Você pode escolher um tipo de gráfico, definir seus eixos e codificações, formatar valores e rótulos de eixos, e formatar o título e a descrição do widget com rich text.

Criar e configurar um gráfico​

Após adicionar um widget de visualização à tela, o painel de Configuração de Visualização aparece no lado direito da tela. Por default, o primeiro dataset listado na tab Dados é selecionado e o tipo de visualização default é um gráfico de barras .

Um widget de visualização em branco e o painel de configuração da visualização.

Para criar um gráfico, siga os seguintes passos:

  1. Selecione um dataset: Use o menu suspenso "Conjunto de dados" para escolher o dataset para sua visualização.
  2. Adicionar filtros (opcional): Clique em Mostrar filtros para aplicar um filtro estático ou parâmetro à sua visualização. Você pode filtrar por qualquer campo. Se o seu dataset incluir um parâmetro, também aparecerá uma opção para aplicá-lo.
  3. Escolha um tipo de visualização: Selecione um tipo de visualização no menu suspenso "Visualização" . Para obter detalhes sobre os tipos de visualização disponíveis e suas configurações, consulte Tipos de visualizaçãoAI/BI dashboard.
  4. Defina os campos dos eixos x e y: Após selecionar um dataset, escolha os campos a serem exibidos nos eixos x e y. Você pode reordenar os campos arrastando-os para a posição desejada. Para o rótulo do gráfico, você pode usar o campo de nome de exibição para renomear o rótulo do eixo.
nota

Se você usar o Genie Code para gerar um gráfico, o dataset e as seleções de visualização serão ajustados automaticamente com base na sua solicitação. Para obter orientações passo a passo sobre como criar visualizações com auxílio AI , consulte Usar Genie Code para criação de dashboards.

visualizar a consulta de visualização​

No modo rascunho, você pode view a consulta SQL completa executada por um widget de visualização, incluindo todos os parâmetros e filtros aplicados. Isso é útil para verificar a precisão dos dados, solucionar problemas com resultados inesperados ou entender como os filtros e parâmetros do painel afetam a consulta subjacente.

  1. Clique no Ícone do menu Kebab. Menu de kebabs no widget de visualização.
  2. Clique em " Ver consulta de visualização" .

Uma janela modal é exibida exibindo a query SQL do widget de visualização. Esta query é específica do widget e retorna apenas os dados necessários para renderizar essa visualização. Não é igual à query do dataset completo. A query reflete o estado atual de quaisquer filtros aplicados. Se o dataset subjacente usar parâmetros, os valores dos parâmetros não serão substituídos na query. Em vez disso, eles aparecem na parte superior do modal para referência.

Formatar títulos e descrições de widgets​

Os títulos e descrições de widgets aceitam texto formatado. Você pode enfatizar termos-chave, criar um link para uma definição ou mostrar o valor atual de um filtro no cabeçalho do widget.

Clique no título ou na descrição de um widget para começar a editar. A formatting toolbar appears above the widget, and both fields prompt you to type @ to reference a filter or a field.

Um widget de gráfico de barras no modo de edição, com a barra de ferramentas de formatação rich text acima dele e texto de espaço reservado nos campos de título e descrição

Formatar texto​

Use a barra de ferramentas de formatação para estilizar o título ou a descrição das seguintes maneiras:

  • Estilo de texto : Ajuste o estilo do bloco, fonte, peso da fonte, tamanho da fonte e cor do texto, e aplique sublinhado. Escolha entre 20 fontes de código aberto no menu suspenso de fontes.
  • Alinhamento : alinhe o texto à esquerda, ao centro ou à direita.
  • Inserir links : clique no ícone de link para abrir o editor de links. Insira o URL e o texto do link a ser exibido.
  • Inserir tabelas : clique no ícone de tabela para adicionar uma tabela.
  • Limpar formatação : Remova toda a formatação do texto selecionado.

Você também pode digitar a sintaxe markdown diretamente. Por exemplo, digitar **Revenue** formata o texto como negrito. Para editar o markdown subjacente, clique no menu kebab Ícone do menu Kebab. > Mostrar markdown . Para obter detalhes sobre a sintaxe básica de markdown, consulte o guia de Markdown.

A formatação também se aplica a referências de filtro e campo. Uma referência herda a formatação do texto ao redor. Você pode colocar um valor referenciado em negrito, colori-lo ou redimensioná-lo para destacá-lo no cabeçalho do widget. Por exemplo, se você colocar Total revenue: em negrito junto com a referência de campo ao lado, os visualizadores verão o valor resolvido em negrito. Uma referência a um filtro ou campo excluído mantém a cor do indicador (removido) , mas ainda assim herda outra formatação, como negrito ou itálico.

Os widgets de texto usam o mesmo editor. Consulte Widgets de texto.

nota

Não é possível inserir imagens no título ou na descrição de um widget. Imagens são suportadas em widgets de texto. Consulte Caminhos de imagem e URLs.

Fazer referência a um filtro ou a um campo​

You can reference a filter or a field in a widget title or description so that the header responds to the dashboard's filters and cross-filter selections. A filter reference reflects the viewer's current selection. Uma referência de campo mostra uma métrica agregada em tempo real.

Por exemplo:

  • Para referenciar um filtro, digite Sales for @region e selecione o filtro region. The title reads Sales for West when a viewer selects West , and updates when the selection changes.
  • To reference a field, type Total revenue: @ and select the revenue field. A referência é resolvida para uma agregação, como Total revenue: $1.2M, e é atualizada quando um visualizador aplica um filtro ou filtro cruzado.

Para adicionar uma referência:

  1. Clique no título ou na descrição do widget para começar a editar.
  2. Digite @ para abrir a lista de filtros e campos disponíveis.
  3. Continue digitando para restringir a lista.
  4. Selecione um filtro ou um campo.

O tipo de autocompletar @ aberto em um título de widget, listando um dataset e seus campos com ícones de tipo de dados

Quando você seleciona um campo, uma agregação default é aplicada com base no tipo de campo. Para alterar o campo, a agregação ou a formatação, clique na referência para abrir um popover de configuração:

  • On the Value tab, change the field or select a different aggregation function. As funções disponíveis dependem do tipo de campo. Para campos numéricos, eles incluem SUM, AVG, MEDIAN, MIN, MAX, COUNT, COUNT DISTINCT, VAR, STD, PERCENTILE, FIRST e LAST.
  • On the Format tab, set number or date formatting, including the number type, abbreviation, precision, group separator, and negative sign. Para obter detalhes sobre a formatação de números, consulte Formatar valores numéricos. A tab Format não é exibida para campos de texto.

A configuração de referência de campo na tab Valor, mostrando o seletor de campos e as opções de agregação

A field reference can target any dataset on the dashboard, not only the widget's own dataset, and a single title or description can reference multiple fields.

As referências têm as seguintes limitações:

  • Widgets de filtro e de parâmetro não podem fazer referência a outros filtros. Isso evita referências circulares entre filtros.
  • Field references are available in visualization widget titles and descriptions only. Elas não estão disponíveis em widgets de controle, como widgets de filtro e de parâmetro.
  • A field reference targets a field from a single dataset. Cross-dataset measures aren't supported. Dashboards that use a semantic model are supported.
  • Se um campo referenciado for renomeado ou removido, a referência exibirá (removed).

Para saber mais sobre como referenciar parâmetros em widgets de texto, consulte Use parâmetros em widgets de texto.

Onde a formatação não é aplicada​

Os locais a seguir mostram o título como texto simples, com a formatação removida. Não dependa da formatação para transmitir significado em um título que aparece nestes locais:

  • Títulos de gráficos e referências de visualização que o Genie exibe, inclusive na janela de bate-papo, em agentes do Genie e no Genie One
  • A lista de widgets no editor de painel
  • Anexos de inscrições de dashboards
  • Dicas de ferramenta de filtro
  • O nome do arquivo de uma exportação de dados download

Outro comportamento de formatação​

A formatação também se comporta de forma diferente nos seguintes casos.

O download de um widget como imagem preserva a formatação do texto.

Quando um widget tem apenas uma linha de altura e mostra seu título, a descrição aparece em uma dica de ferramenta atrás de um ícone de informação em vez de ao lado do título. Para mostrar a descrição em linha, aumente a altura do widget ou oculte o título.

Aplicar formatação ao gráfico​

Os gráficos incluem opções de formatação personalizáveis para eixos, cores, rótulos e dicas de ferramentas. As opções de formatação variam de acordo com o tipo de gráfico e os valores dataset .

A captura de tela a seguir destaca os menus de kebab usados para formatar os eixos x e y.

Uma captura de tela destacando o menu de kebab para usar na formatação dos eixos x e y.

Formatar configurações do eixo​

Para formatar o eixo x ou o eixo y, use o Ícone do menu Kebab. menu de kebab na respectiva seção do eixo X ou do eixo Y do painel de edição de visualização.

Configure as seguintes definições:

  • Exibir título do eixo: Ativado por default. Insira um título personalizado ou desmarque a caixa de seleção para ocultar o título do eixo.
  • Exibir valores do eixo: Ativado por default. Desmarque a caixa de seleção para ocultar os valores do eixo.

Dependendo do tipo de dados representados, controles adicionais aparecem.

Para dados numéricos:

  • Intervalo do eixo : selecione como o intervalo do eixo é determinado:

    • Default : Usar um intervalo automático. Em um gráfico facetado, todos os subgráficos compartilham um único intervalo para que sejam diretamente comparáveis.
    • Por faceta : Em um gráfico com facetas, dimensiona o eixo de acordo com os dados de cada subgráfico. Isso não tem efeito quando o gráfico não é facetado. Consulte Criação de facetas.
    • Personalizado : defina valores Mínimo e Máximo fixos para o eixo.
  • Inverter eixo: Selecione Inverter Eixo para exibir os valores do eixo em ordem decrescente.

  • Função escala: Escolha Linear ou logarítmica (simétrica) .

  • Clique em Formatar para view opções de formatação adicionais. A opção Auto formata automaticamente o seu gráfico e está selecionada por default. Clique em Personalizar para ver opções de formatação adicionais. Consulte Formatar valores numéricos.

Para dados categóricos:

  • Ângulo do rótulo: Escolha o ângulo em que o rótulo será aplicado. A opção Automático está selecionada por default.
  • Ordenar: Escolha como ordenar os valores categóricos no eixo:
    • Alfabético : Classificar os nomes das categorias em ordem alfabética.

    • Por campo : Classificar por um valor de campo de medida em ordem crescente ou decrescente. Após selecionar a direção da classificação, escolha qual campo usar:

      • Eixo Y : Classificar pelo campo de medida exibido no eixo Y.
      • Campo : Classificar por qualquer outro campo de medida no dataset, mesmo que não seja exibido no gráfico. Selecione o campo na dropdown e escolha a agregação (SOMA, MÍNIMO, MÁXIMO ou CONTAGEM). Isso é útil para ordenar categorias por métricas que fornecem contexto sem sobrecarregar a visualização.
    • Personalizado : Organize os valores em uma ordem específica. Posicione o cursor sobre um valor e use a alça para arrastá-lo até a posição desejada.

Um gráfico com rótulos e opções de classificação aplicadas ao eixo x.

nota

Caso alguma das opções listadas não esteja disponível, ela não poderá ser aplicada ao tipo de gráfico selecionado.

Formatar valores numéricos​

Você pode formatar números para rótulos de marcação de eixo, rótulos de dados e dicas de ferramentas. Para acessar as opções de formatação:

  1. Clique no Ícone do menu Kebab. Menu de kebab ao lado do eixo X ou do eixo Y no painel de configuração do gráfico.
  2. Clique em Formatar e escolha uma das seguintes opções:
  • Tipo: Nenhum, Moeda ( $ ), Percentagem ( % )
  • Abreviatura: Nenhuma, Compacto, Científico
  • Casas decimais: Máximo, Exato, Todas ou um número personalizado de casas decimais.
  • Separador de grupo: Opcionalmente, inclua uma vírgula ou outro separador.
  • Sinal negativo: Escolha como os números negativos serão exibidos. Selecione -123,45 (default) para um sinal de menos padrão ou selecione (123,45) para usar parênteses no estilo contábil.
nota

Estão disponíveis diferentes formatos de moeda. Após selecionar a moeda , escolha a opção desejada no menu suspenso.

Personalize os elementos do gráfico​

You can format chart legends, colors, marker shapes, line patterns, tooltips, and value labels.

Cores do gráfico​

Para alterar as cores do gráfico:

  1. Clique em uma cor na tabela para abrir o seletor de cores.
  2. Insira um valor HEX ou RGB para obter a cor exata.
  3. Clique no Ícone do menu Kebab. No menu Kebab, na seção Cor , você pode ajustar a opacidade de todas as cores.

Cores consistentes entre widgets​

Quando um gráfico usa cores por um campo categórico, os painéis usam automaticamente a mesma cor para o mesmo valor em todos os widgets do painel. Por exemplo, se um gráfico mostra Australia em uma cor, todos os outros gráficos no painel que usam cores pelo mesmo campo mostram Australia nessa cor.

Os widgets compartilham cores apenas quando são coloridos pelo mesmo campo do mesmo dataset. Um campo com o mesmo nome de um dataset diferente mantém suas próprias cores. A consistência de cores é limitada a um único painel, portanto, as cores não são transferidas entre painéis. Isto se aplica a Colorir por campo e não se aplica a Colorir por série .

Para usar uma cor específica para um valor, defina-a no seletor de cores. Uma cor definida manualmente tem precedência sobre a atribuição automática.

Para definir a cor automática para um valor em todo o dashboard (em vez de um widget por vez), use mapeamentos de cores nas configurações de tema do dashboard. Consulte Criar ou atualizar o tema do workspace.

A seção de mapeamentos de cores da tab Paleta de cores, mostrando nomes de valores mapeados para amostras de cores.

Lenda​

Clique no Ícone do menu Kebab. Na seção Cor , você encontrará o menu "kebab" para exibir opções que permitem alterar a visibilidade, o título ou a posição da legenda do gráfico. As seguintes opções estão disponíveis:

  • Exibir legenda: Use a caixa de seleção para mostrar ou ocultar a legenda.
  • Exibir título da legenda: Use a caixa de seleção para mostrar ou ocultar o título da legenda. Quando o título estiver visível, você pode digitar para substituir o valor default , que é o nome da coluna.
  • Posição da legenda: Use o menu suspenso para ajustar a posição da legenda no widget de visualização. As legendas podem ser posicionadas na parte superior, inferior, esquerda ou direita da visualização.

Dicas de ferramentas​

As dicas de ferramentas exibem medidas precisas dos dados sob o ponteiro. Por default, eles exibem valores do eixo x, do eixo y e de quaisquer campos de cor/agrupamento. Para adicionar mais campos a uma dica de ferramenta:

  1. Clique no ícone de adição Ícone de mais (+). na seção Tooltip do editor de visualização.
  2. Use o menu suspenso para selecionar campos adicionais ou use a caixa de entrada de texto para pesquisar por nome.
nota

Se a seção de dicas de ferramentas não estiver presente no editor de visualização, esse tipo de gráfico não oferece suporte à personalização de dicas de ferramentas.

Valor​

Use o botão para ativar ou desativar a rotulagem de dados. Quando ativada, você pode escolher como o rótulo será exibido:

  • Auto : Exibe os valores do eixo y como rótulo.
  • Campo : Selecione um campo específico para exibir como rótulo. Você pode aplicar transformações (como SOMA ou MÉDIA) e escolher opções de formatação para o campo selecionado.

Valores nulos não são exibidos como rótulo no gráfico. Você pode usar lógica condicional para exibir rótulos seletivamente.

A consulta a seguir cria um dataset onde os rótulos aparecem apenas para pontos de dados específicos:

SQL
SELECT
*,
CASE
WHEN pickup_zip = 10009 THEN fare_amount
ELSE NULL
END AS custom_label
FROM
samples.nyctaxi.trips

Quando você usa custom_label como campo do rótulo de valor, apenas os pontos de dados onde pickup_zip = 10009 exibem o rótulo mostrando o fare_amount. Todos os demais pontos de dados com valores nulos aparecem no gráfico sem rótulo.

Uma visualização mostrando apenas uma linha com o valor rótulo.

Configurações de tamanho​

A configuração Tamanho controla as dimensões visuais de gráficos de linhas, gráficos de dispersão, gráficos de bolhas e mapas de pontos. Sua utilização depende do tipo de gráfico:

Gráficos de linhas:

  • Se nenhuma série for especificada na área Tamanho , o controle deslizante altera a espessura de todas as linhas uniformemente.
  • Se as séries forem especificadas na área Tamanho , você poderá definir valores de espessura diferentes para cada série.

Gráficos de dispersão e de bolhas:

  • Adicione um campo à configuração de Tamanho para variar o tamanho do marcador de ponto com base em uma métrica.
  • Quando o tamanho é baseado em um campo de dados, o gráfico se torna um gráfico de bolhas, onde o tamanho de cada ponto reflete o valor da métrica.

Mapas de pontos: Use a configuração Tamanho para variar o tamanho dos marcadores do mapa com base em um campo quantitativo, mostrando a magnitude em diferentes localizações geográficas.

Marcador​

On line charts, the Marker setting draws a marker at each pontos de dados along a line. Click the marker swatch to set one shape for every point, or click the Ícone de mais (+). plus icon in the Marker section to vary the marker shape by a categorical field, such as a different shape for each series. Available shapes include a circle, square, diamond, cross, X, star, and triangles.

A configuração Marker se aplica apenas a gráficos de linha. Em gráficos de dispersão, use a configuração Shape em vez disso.

Shape​

Em gráficos de dispersão, a configuração Shape controla a forma de cada ponto. Clique na amostra de forma para definir uma forma para cada ponto, ou clique no ícone de adição Ícone de mais (+). na seção Shape para variar a forma por um campo categórico, como uma forma diferente para cada categoria. As formas disponíveis incluem círculo, quadrado, losango, cruz, X, estrela e triângulos.

A configuração Shape se aplica somente a gráficos de dispersão. Em gráficos de linhas, use a configuração Marker .

Padrão​

Em gráficos de linha e combinados, a configuração Pattern controla o estilo de traço de cada linha. Clique no ícone de adição Ícone de mais (+). na seção Pattern para escolher um campo categórico que varie o estilo de traço de cada linha, como uma linha contínua para uma série e uma linha tracejada para outra. Os estilos disponíveis são solid, dashed e dotted.

As configurações Marker e Shape não estão disponíveis em gráficos combinados ou gráficos que plotam várias métricas. Nesse tipo de gráfico, use a configuração Pattern para distinguir séries de linhas.

Linhas de grade​

Os gráficos permitem ativar e desativar as linhas de grade para melhorar a legibilidade. As linhas de grade aparecem por default nos tipos de gráficos compatíveis e ajudam os visualizadores a interpretar os pontos de dados, fornecendo linhas de referência visuais alinhadas com os valores dos eixos.

Para ativar/desativar as linhas de grade:

  1. No painel de configuração de visualização, localize as opções de linha de grade.
  2. Use o botão para mostrar ou ocultar as linhas de grade do gráfico.

As linhas de grade se ajustam automaticamente com base nas cores de fundo personalizadas e nas configurações de formatação dos eixos.

anotação​

Anotações são linhas de referência horizontais ou verticais que você pode adicionar a gráficos para rastrear limites, metas ou benchmarks. Linhas de anotação podem ser um valor constante fixo ou impulsionadas por seus dados, como uma média ou uma medida específica.

Gráfico com linhas de anotação.

Os seguintes tipos de gráficos suportam anotação:

  • Constante e Personalizado : Área, Barras, Caixa, Combinado, Mapa de calor, Histograma, Linhas, Dispersão e Cascata
  • Agregação : Somente área, barra, caixa, linha e dispersão. Não disponível em gráficos com disposição de pilha de 100%.

Para adicionar uma anotação:

  1. No painel de configuração de visualização, localize a seção de anotação .

  2. Clique no Ícone de mais (+). ícone de mais para adicionar uma nova anotação.

  3. Selecione a orientação da linha:

    • Horizontal : Desenha uma linha paralela ao eixo x em um valor de eixo y especificado.
    • Vertical : Desenha uma linha paralela ao eixo y em um valor de eixo x especificado.
  4. Selecione o tipo de anotação e configure-o:

    • **Constante**: Insira um valor fixo onde a linha deve aparecer.
    • Agregar Y (horizontal) / Agregar X (vertical): Selecione uma agregação ( Média , Mín . ou Máx .). A posição da linha é calculada como uma agregação sobre os dados subjacentes do gráfico.
    • Personalizado: Selecione um campo ou medida do seu dataset. A posição da linha é calculada em uma consulta separada. Se um campo agregado for selecionado, uma única linha é desenhada. Se um campo não agregado for selecionado, uma linha é desenhada por linha retornada.
  5. (Opcional) Insira um rótulo. O rótulo aparece no gráfico ao lado da linha.

  6. (Opcional) Clique no seletor de cores para personalizar a cor da linha.

Você pode adicionar várias anotações a um único gráfico para acompanhar diferentes pontos de limite ou de referência.

Gerar uma previsão​

Use a PrevisãoAI (Prévia Pública) para aplicar previsões preditivas a gráficos de linhas e visualizar tendências e padrões futuros. Seu gráfico de linhas deve ter um campo de data temporal no eixo x e um único campo numérico no eixo y.

Para criar um gráfico com previsão AI :

  • Com o gráfico de linhas selecionado, clique em Ícone de mais (+). Ícone de mais (+) à direita de Previsão .
  • Clique em Clonar com Previsão AI na caixa de diálogo que aparece. Um novo gráfico de linhas é criado com a previsão aplicada.

Para saber mais sobre a função que gera a previsão, consulte a funçãoai_forecast.

É gerada uma previsão para um gráfico de linhas.

Facetamento​

Adicione uma dimensão à codificação Facet para repetir um gráfico ou contador para todos os valores nessa dimensão, também conhecido como gráficos trellis ou de múltiplos painéis. By default, os subgráficos compartilham um intervalo para cada eixo contínuo para que possam ser diretamente comparados. Para adicionar facetas:

  1. Clique no ícone de mais Ícone de mais (+). na seção Facet do editor de visualização.
  2. Utilize o menu suspenso para selecionar um campo de dimensão.

No Ícone do menu Kebab. No menu "kebab" ao lado de "Facet" , você pode opcionalmente definir o número de linhas e colunas na grade subjacente. Os valores que ultrapassam os limites da grade rolam no gráfico.

Para dimensionar um eixo numérico para os dados de cada subgráfico em vez de compartilhar um intervalo, defina o Intervalo de eixo como Por faceta . Os eixos de faceta categórica sempre mostram as categorias próprias de cada subgráfico. Consulte Formatar configurações de eixo.

Você também pode criar facetas em um contador. A adição de uma dimensão Facet a um contador renderiza um bloco de contador por valor de dimensão na mesma grade. Como um contador não tem eixos, as opções de intervalo de eixos, incluindo Por faceta , não se aplicam. Quando o contador exibe um gráfico de linhas (sparkline), todos os blocos compartilham um domínio para que as tendências dos gráficos de linhas permaneçam comparáveis entre os blocos.

Um gráfico de barras dividido por produto em quatro subgráficos, cada um mostrando a contagem diária de registros ao longo do tempo.

Valores de configuração : Para este exemplo, os seguintes valores foram definidos:

  • conjunto de dados: samples.bakehouse.sales_transactions

  • Eixo X:

    • Campo: dateTime
    • Transformar: Daily
  • Eixo Y:

    • Campo: COUNT(*)
  • Faceta:

    • Campo: product

Outros tipos de visualização​

Para saber mais sobre como trabalhar com visualizações de tabela, consulte Visualizações de tabela e tabela dinâmica.

Para saber mais sobre como trabalhar com visualizações de mapas, consulte Visualizações de mapas.