Pular para o conteúdo principal

Instalar a extensão de IDE do Databricks

Este artigo descreve como instalar e abrir a extensão de IDE do Databricks e, em seguida, configurar um projeto para a extensão usar. Consulte Databricks IDE extension.

Requisitos​

Para usar a extensão de IDE do Databricks:

  • Você deve ter pelo menos um workspace do Databricks disponível, e o workspace deve conter pelo menos um cluster do Databricks. Se você não tiver um cluster disponível, poderá criar um cluster como parte da instalação da extensão de IDE do Databricks.
nota

Databricks SQL armazéns não são suportados por essa extensão.

  • Você deve ter a versão 1.104.0 ou acima do Visual Studio Code instalada. Para view sua versão instalada, clique em Code > About Visual Studio Code no menu principal no Linux ou macOS e em Help > About no Windows. Para fazer o download, instalar e configurar o Visual Studio Code, consulte Configurando o Visual Studio Code.

  • O Visual Studio Code deve ser configurado para codificação Python, incluindo a disponibilidade de um interpretador Python. Para obter detalhes, consulte Como começar com Python no código VS.

Instale e abra a extensão​

  1. No Visual Studio Code, abra as Extensões view (Exibir > Extensões no menu principal).

  2. Em Search Extensions (Pesquisar extensões) no marketplace , digite Databricks .

  3. Clique na extensão Databricks e, em seguida, clique em Install (Instalar ).

nota

Certifique-se de escolher a extensão que é de propriedade verificada da Databricks .

Instale a extensão do mercado de extensões 4. Clique em Recarregar necessário ou reinicie o Visual Studio Code.

  1. (Opcional) Quando solicitado, instale ferramentas de IA para que seus agentes de codificação funcionem de forma eficaz com o Databricks. Consulte Instalar e usar ferramentas de IA.

  2. Para abrir a extensão, na barra lateral, clique no ícone Databricks .

  3. Configure a extensão de IDE do Databricks para se conectar ao seu workspace do Databricks. Consulte Configurar seu projeto do Databricks.

Instale uma versão diferente da extensão​

Se você deseja instalar uma versão específica da extensão de IDE do Databricks, como uma versão anterior, ou atualizar para a versão de lançamento, no Visual Studio Code, na view Extensions ( View > Extensions no menu principal):

  1. Clique em Databricks e, em seguida, clique na seta Uninstall dropdown.

  2. Clique em Instalar outra versão e escolha uma versão.

    Instale outra versão da extensão

    Como alternativa, para atualizar para a versão de lançamento, clique em Alternar para a versão de lançamento .

  3. Para aplicar a alteração de versão, clique em Reiniciar extensões ou reinicie o Visual Studio Code.

Para obter mais informações, consulte a documentação da extensão do Visual Studio Code.

Desinstale a extensão​

Se você precisar desinstalar a extensão do Databricks para IDE, no Visual Studio Code, clique em View > Extensions no menu principal e, em seguida:

  1. Na lista de extensões, selecione a extensão Databricks .
  2. Clique em Desinstalar .
  3. Clique em Recarregar necessário ou reinicie o Visual Studio Code.