Databricks Runtime 11.x migration guide

This guide helps you migrate your Databricks workloads to the latest version of Databricks Runtime 11.x. To do so, Databricks recommends that you migrate your workloads in the following order:

  • If your workloads are currently running on Databricks Runtime 10.4 LTS or above, you can migrate directly to the latest version of Databricks Runtime 11.x, as described later in this article.

  • If your workloads are currently running on Databricks Runtime 10.3 or below, do the following:

    1. Migrate to Databricks Runtime 10.4 LTS first. See the Databricks Runtime 10.x migration guide.

    2. Follow the guidance in this article to migrate from Databricks Runtime 10.4 LTS to the latest version of Databricks Runtime 11.x.

Apache Spark migration guidance

The most recent version of the Databricks Runtime is 11.1, powered by Apache Spark 3.3.0. For Spark-specific migration information, click on one or more of the following links by Databricks Runtime version to view the corresponding Apache Spark Migration Guide. For reference, Databricks Runtime 10.4 LTS is powered by Apache Spark 3.2.1.

Databricks Runtime version

Apache Spark version

11.0 - 11.1

3.3.0

10.4 LTS - 10.5

3.2.1

Databricks Runtime behavior changes

The following notable behavior changes were introduced into each of the following DBR 11.x releases.

Databricks Runtime system environment properties, features, and libraries

For information about system environment properties as well as new, changed, and deprecated features and libraries in Databricks Runtime releases from Databricks Runtime 10.4 LTS to the latest version of Databricks Runtime 11.x, see the following:

Post-release maintenance updates are listed in Databricks runtime maintenance updates.