Databricks Runtime 5.5 ML Extended Support

Databricks released this image in July 2021. It is supported through December 2021.

Databricks Runtime 5.5 ML Extended Support is intended for customers who are on the unsupported Databricks Runtime 5.5 ML LTS but are unable to migrate to Databricks Runtime 7.x ML or 8.x ML. Databricks Runtime 5.5 ML Extended Support uses Ubuntu 18.04.5 LTS instead of the deprecated Ubuntu 16.04.6 LTS distribution used in the original Databricks Runtime 5.5 ML. Ubuntu 16.04 reached end of life on April 1, 2021.

Databricks continues to recommend that you migrate your workloads to Databricks Runtime 7.x ML or 8.x ML as soon as you can to get the benefits of Apache Spark 3.x and the many new features and improvements built into these newer runtimes. For migration information, see Databricks Runtime 7.x migration guide.

These release notes list the differences between Databricks Runtime 5.5 ML Extended Support and the original Databricks Runtime 5.5 ML. For all other details about this release, see the release note for the original Databricks Runtime 5.5 LTS for Machine Learning.

Differences between Databricks Runtime 5.5 ML Extended Support and Databricks Runtime 5.5 ML

The following environment details and libraries are different from those in Databricks Runtime 5.5 ML.

System environment

  • Operating System: Ubuntu 18.04.5 LTS
  • Java: Zulu 8.54.0.21-CA-linux64 (build 1.8.0_292-b10)
  • Python2: Python 2.7.15
  • Python3: Python 3.6.13 (upgraded from 3.6.5)

Python2 libraries

  • backports.functools-lru-cache upgraded from 1.5 to 1.6.4
  • ipython-genutils 0.2.0
  • ipython_genutils removed

Python3 libraries

  • certifi upgraded from 2018.04.16 to 2021.5.30
  • cffi upgraded from 1.11.5 to 1.14.5
  • cryptography upgraded from 2.2.2 to 2.3.1
  • psycopg2 upgraded from 2.7.5 to 2.8.6
  • setuptools upgraded from 39.1.0 to 52.0.0.post20210125
  • wheel upgraded from 0.31.1 to 0.36.2
  • ipython-genutils 0.2.0
  • xgboost 0.90
  • ipython_genutils removed

R libraries

  • foreign downgraded from 0.8-71 to 0.8-70
  • Rserve upgraded from 1.8-6 to 1.8-8