Databricksノートブックのインターフェイスと操作

ノートブックツールバーには、ノートブックの管理と編集に使用できるメニューとアイコンが含まれています。

ノートブックツールバー

ノートブック名の横には、ノートブックのデフォルト言語を変更できるボタンがあります。ノートブックが Databricks Git フォルダーに含まれている場合は、 [Git] ダイアログを開きます

以前のバージョン のノートブックを表示するには、[最後の編集...] をクリックします。メニューの右側にあるメッセージ。

更新されたセル設計

プレビュー

この機能はパブリックプレビュー段階です。

更新されたセル設計が利用可能です。 このページには、両方のバージョンのセル設計の使用方法に関する情報が含まれています。 新しい UI の向きとよく寄せられる質問への回答については、「 新しいセル UI の向き」を参照してください。

新しいセル デザインを有効または無効にするには、ワークスペースで エディター設定 ページを開きます。 サイドバーで [ Developer (開発)] をクリックします。 [実験的な機能] で、[新しいセル UI] を切り替えます。

ノートブックのセル

ノートブックには、コード セルと Markdown セルの 2 種類のセルのコレクションが含まれています。 コード セルには、実行可能なコードが含まれています。 Markdown セルには、セルの実行時にテキストとグラフィックにレンダリングされる Markdown コードが含まれており、コードの文書化や説明に使用できます。 ノートブックにセルを追加または削除して、作業を構造化できます。

単一のセルやセルのグループを実行したり、ノートブック全体を一度に実行したりできます。ノートブックのセルには最大10MBを含めることができます。ノートブックのセル出力は20MBに制限されています。

ノートブックのツールバーのアイコンとボタン

以下の表は、ツールバーの右側にあるアイコンとボタンについて説明しています。

アイコン

説明

「すべて実行」ボタン 「実行を停止」ボタン

すべてのセルを実行したり、実行を停止したりします。このボタンの名前はノートブックの状態によって変ります。

ノートブックヘッダーのコンピュートセレクター

コンピュートセレクターを開きます。ノートブックがクラスターまたは SQLウェアハウスに接続されている場合、このボタンにはコンピュート リソースの名前が表示されます。

ノートブックヘッダーのジョブスケジューラ

ジョブスケジューラーを開きます。

ノートブックヘッダーのDLTセレクター

Delta Live Tablesを開きます。このボタンは、ノートブックがDelta Live Tablesパイプラインの一部である場合にのみ表示されます。

ノートブックヘッダーの共有ボタン

権限ダイアログを開きます。

データを閲覧する

プレビュー

この機能はパブリックプレビュー段階です。

ノートブックで使用できるテーブルとボリュームを調べるには、ノートブックの左側をクリックして ノートブックデータアイコン スキーマブラウザを開きます。 詳細については、「 データの参照 」をご参照ください。

セルアクションメニュー

セルの操作メニューでは、セルの切り取りとコピー、ノートブック内のセルの移動、コードや結果の非表示を行うことができます。 メニューの外観は、元の UI と新しい UI で異なります。 このセクションには、両方のバージョンの手順が含まれています。

ワークスペースで Databricks Assistant が有効になっている場合は、コード セルでそれを使用して、コードのヘルプや提案を取得できます。 セルで Databricks Assistant テキスト ボックスを開くには、セルの右上隅にある [Databricks Assistant] アイコン Databricks アシスタントアイコン をクリックします。

セルの右上隅にあるセル言語ボタンを使用して、コードとマークダウンの間でセルを変更したり、コードセルの言語を変更したりすることが簡単にできます。

[セルの言語] ボタン

セル アクション メニュー (元の UI)

セルアクションメニュー

このメニューからコードセルを実行することもできます。

セルアクションメニュー - 実行

セルアクションメニューには、セルを非表示にしたり、セルセルの最小化アイコンを削除を削除したりするためのボタンも含まれています。

Markdown セルの場合、セルをダッシュボードに追加するオプションもあります。 詳細については、「 ノートブックのダッシュボード」を参照してください。

ダッシュボード

新しい UI でのセルの操作

次のスクリーンショットは、ノートブック セルの右上に表示されるアイコンを示しています。

右上のセル アイコン - 新しい UI

言語セレクタ: セルの言語を選択します。

Databricks アシスタント: セル内のコード候補の Databricks Assistant を有効または無効にします。

細胞の焦点: セルを拡大すると、編集しやすくなります。

セルアクションメニューの表示: セルのアクションメニューを開きます。 このメニューのオプションは、コードセルとMarkdownセルで若干異なります。

セル アクション メニュー - 新しい UI

新しい UI でコード セルを実行するには、コード セルの左上にある下向き矢印をクリックします。

セル実行メニュー - 新しい UI

セルが実行されると、セル実行メニューの右側に通知が表示され、セルが最後に実行された時刻と実行時間が表示されます。 通知の上にカーソルを置くと、詳細が表示されます。

最終実行イメージ

Markdown セルまたは表形式の結果を持つセルをダッシュボードに追加するには、セル アクション メニューから [ ダッシュボードに追加 ] を選択します。 詳細については、「 ノートブックのダッシュボード」を参照してください。

セルを削除するには、セルの右側にあるごみ箱アイコンをクリックします。 このアイコンは、セルの上にカーソルを置いたときにのみ表示されます。

セルのごみ箱アイコン

セル内のコードにコメントを追加するには、コードを強調表示します。 セルの右側に、コメント アイコンが表示されます。 アイコンをクリックして、コメントボックスを開きます。

commment アイコン

セルを上下に移動するには、セルの左上隅の外側をクリックしたまま [セルの移動] アイコン 、セルを新しい位置にドラッグします。 また、セルのアクションメニューから「 へ移動」または「 下へ移動 」を選択することもできます。

セルの作成

ノートブックには、コードと Markdown の 2 種類のセルがあります。 Markdown セルの内容が HTML にレンダリングされます。 たとえば、次のスニペットには、レベル 1 の見出しのマークアップが含まれています。

%md ### Libraries
Import the necessary libraries.

次のようにレンダリングされます。

レンダリングされた Markdown の例

セルを作成する (元の UI)

元の UI で新しいセルを作成するには、上部または下部のセルにカーソルを合わせてアイコンをクリックします セルを追加 。 ノートブックのセルメニューを使用して、[上にダウンキャレットセルを追加]または[下にセルを追加]を選択することもできます。

コードセルの場合は、セルにコードを入力するだけです。Markdownセルを作成するには、セルの言語ボタンからMarkdownを選択するか、セルの上部に%mdと入力します。

セルの作成 (新しい UI)

新しい UI で新しいセルを作成するには、上部または下部のセルにカーソルを合わせます。 [コード] または [テキスト] をクリックして、それぞれコードまたはマークダウン セルを作成します。

新しいセルを作成するためのボタン

セルの切り取り、コピー、貼り付け

セルを切り取ってコピーするには、いくつかのオプションがあります。 Safariブラウザを使用している場合は、キーボードショートカットのみを使用できます。

  • 元のUIまたは新しいUIのセルアクションメニューから、「セルの切り取り」または「セルのコピー」を選択します。

  • キーボードショートカットを使用する:Command-XまたはCtrl-Xで切り取り、Command-CまたはCtrl-Cでコピーします。

  • ノートブックの上部にある「編集」メニューを使用します。「切り取り」または「コピー」を選択します。

セルを切り取りまたはコピーした後、それらのセルをノートブック内の別の場所、別のノートブック、または別のブラウザタブまたはウィンドウのノートブックに貼り付けることができます。セルを貼り付けるには、キーボードショートカットCommand-VまたはCtrl-Vを使用します。セルは現在のセルの下に貼り付けられます。

切り取りまたは貼り付けの操作を元に戻すには、キーボード ショートカットの Command-Z または Ctrl-Z、またはメニュー オプションの [編集] > [切り取りを取り取りセルを元に戻す] または [編集] > [貼り付けたセルを元に戻す] を使用します。

隣接するセルを選択するには、Markdownセルをクリックし、Shift + UpまたはDownを使用して、その上または下のセルを選択します。編集メニューを使用して、選択したセルをグループとしてコピー、カット、ペースト、削除できます。すべてのセルを選択するには、「編集」>「すべてのセルを選択」を選択するか、コマンドモードのショートカットCmd+Aを使用します。

ノートブックの目次

自動生成された目次を表示するには、ノートブックの左上(左サイドバーと一番上のセルの間)にあるアイコンをクリックします。 目次は、ノートブックで使用される Markdown 見出しから生成されます。 新しい UI を使用している場合は、タイトル付きのセルも目次に表示されます。

TOCを開く

セルの表示オプション

ノートブックには 3 つの表示オプションがあります。 [ 表示 ] メニューを使用して、表示オプションを変更します。

  • 標準ビュー:結果がコードセルの直後に表示されます。

  • 結果のみ:結果のみが表示されます。

  • 並列:コードと結果のセルが並べて表示されます。

新しい UI では、セルの余白 (セルの左右の領域) のアイコンからアクションを使用できます。 たとえば、セルを上下に移動するには、左の余白にあるグリップ ドット [セルの移動] アイコン を使用します。 セルを削除するには、右側の余白にあるごみ箱アイコンを使用します。

編集を容易にするには、フォーカスモードアイコン セルフォーカスアイコン をクリックして、セルを全幅で表示します。 フォーカスモードを終了するには、 をクリックします セルフォーカスアイコンを終了する。 また、[ 表示] > [中央揃えレイアウト] をオフにして、セルの表示幅を拡大することもできます。

ノートブック内のすべてのセルを業界標準の行の長さと間隔に合わせて自動的に書式設定するには、[ノートブックの編集] > [ 書式設定] を選択します。

行番号とコマンド番号

行番号またはコマンド番号を表示または非表示にするには、「表示」メニューから「行番号」または「コマンド番号」を選択します。行番号については、キーボードショートカットControl+Lを使用することもできます。

行番号またはコマンド番号を有効にすると、Databricksによって設定が保存され、そのブラウザでは他のすべてのノートブックでも表示されるようになります。

行番号とコマンド番号 (元の UI)

セルの上のコマンド番号は、その特定のコマンドにリンクしています。 セルのコマンド番号をクリックすると、そのコマンドに固定されるように URL が更新されます。 ノートブック内の特定のコマンドへの URL リンクを取得するには、コマンド番号を右クリックして [リンク アドレスのコピー] を選択します。

行番号とコマンド番号 (新しい UI)

新しい UI では、行番号はデフォルトでオフになっています。 有効にするには、[ 行番号の表示] > を選択します。 セルがエラー状態の場合、選択内容に関係なく行番号が表示されます。

コマンド番号を切り替えるには、 [表示] > [コマンド番号]を選択します。

新しい UI には、セルのコマンド番号リンクは含まれていません。 ノートブック内の特定のコマンドへの URL リンクを取得するには、クリック セルフォーカスアイコン してフォーカス モードを開き、ブラウザーのアドレス バーから URL をコピーします。 フォーカスモードを終了するには、 をクリックします セルフォーカスアイコンを終了する

セルのタイトルを追加する

元のUIを使用してセルにタイトルを追加するには、 セルのアクションメニューから 「タイトルを表示 」を選択します。

新しい UI を使用してセルにタイトルを追加するには、次のいずれかの操作を行います。

  • セルの上部の中央に表示されているセル番号をクリックし、タイトルを入力します。

  • セルの操作メニューから [ タイトルの追加 ] を選択します。

新しい UI では、タイトルのあるセルが ノートブックの目次に表示されます。

セルタイトルを追加

ノートブックをダークモードで表示する

ノートブックをダークモードで表示することもできます。ダークモードをオンまたはオフにするには、「表示」>「テーマ」を選択し、「ライトテーマ」または「ダークテーマ」を選択します。

セルの内容の非表示と表示

セルの内容は、セル コードと、セルの実行によって生成された結果で構成されます。 セルの右上にあるセルの アクションメニューを使用して、セルの コードと結果を表示または非表示にすることができます。

関連する機能については、「 折りたたみ可能な見出し」を参照してください。

セルの内容の表示と非表示 (元の UI)

セルコードまたは結果を非表示にするには、 をクリックしダウンキャレット、「コードを隠す」または「結果を隠す」を選択します。また、セルの最初の行のみを表示するように選択 セルの最小化 することもできます。

非表示のセルコードまたは結果を表示するには、「表示」リンクをクリックします。

非表示のコードと結果を表示する

セルの内容の表示と非表示 (新しい UI)

セルコードまたは結果を非表示にするには、セルの右上にあるケバブメニュー セルケバブアイコン をクリックし、[ コードを 非表示]または [結果を非表示]を選択します。 [ セルを折りたたむ ] を選択して、セルの最初の行のみを表示することもできます。 折りたたまれたセルを展開するには、 [セルの展開] を選択します。

非表示のセルコードまたは結果を表示するには、表示アイコンをクリックします。 アイコンを表示

折りたたみ可能な見出し

Markdown 見出しを含むセルの後に表示されるセルは、見出しセルに折りたたむことができます。 ノートブック全体で Markdown 見出しを含むセルの後のセルを展開または折りたたむには、[表示] メニューの [すべての見出しを折りたたむ] を選択します。このセクションの残りの部分では、セルのサブセットを展開または折りたたむ方法について説明します。

関連する機能については、「 セルの内容の表示と非表示」を参照してください

見出しの展開と折りたたみ (元の UI)

この図は、次の 2 つのセルが折りたたまれたレベル 2 の見出し MLflow セットアップ を示しています。

元の UI で折りたたまれたセル

見出しを展開したり折りたたんだりするには、「+」および「-」をクリックします。

見出しの展開と折りたたみ (新しい UI)

この図は、次の 2 つのセルが折りたたまれたレベル 2 の見出し MLflow セットアップ を示しています。

新しい UI の折りたたまれたセル

見出しを展開したり折りたたんだりするには、Markdown セルの上にカーソルを置きます。 セルの左側に表示される矢印をクリックします。

ノートブック用のコンピュートリソース

このセクションでは、ノートブック コンピュート リソースのオプションについて説明します。 Databricks クラスター上でノートブックを実行することもできます。また、SQL コマンドの場合は、SQL アナリティクス用に最適化されたコンピュートの一種であるSQL ウェアハウスを使用するオプションもあります。

ノートブックをクラスターにアタッチする

ノートブックをクラスターにアタッチするには、 「クラスターCan Attach To 」レベルのアクセス許可が必要です。

重要

ノートブックがクラスターに接続されている限り、 ノートブックに対する 実行可能権限を持つユーザーはクラスターにアクセスするための暗黙的な権限を持ちます。

ノートブックをクラスターにアタッチするには、ノートブックツールバーの コンピュートセレクター をクリックし、ドロップダウンメニューから クラスター を選択します。

メニューには、最近使用したクラスターや現在実行中のクラスターの一部が表示されます。

ノートブックをアタッチ

使用可能なすべてのクラスターから選択するには、「さらに表示…」をクリックします。クラスター名をクリックしてドロップダウンメニューを表示し、既存のクラスターを選択します。

「その他のクラスター」ダイアログ

ドロップダウン メニューから [ 新しいリソースの作成] を選択して 、新しいクラスターを作成する こともできます。

重要

アタッチされたノートブックには、以下のApache Spark変数が定義されています。

クラス

変数名

SparkContext

sc

SQLContext/HiveContext

sqlContext

SparkSession (Spark 2.x)

spark

SparkSessionSparkContext、またはSQLContextの作成は行わないでください。これを行うと、一貫性のない動作が発生します。

SQLウェアハウスでノートブックを使用する

ノートブックが SQL ウェアハウスに接続されている場合、SQL セルと Markdown セルを実行できます。 他の言語 (Python や R など) でセルを実行すると、エラーがスローされます。 SQL ウェアハウスで実行された SQL セルは、SQL ウェアハウスのクエリ履歴に表示されます。 クエリを実行したユーザーは、出力の下部にある経過時間をクリックすると、ノートブックからクエリ プロファイルを表示できます。

ノートブックを実行するには、Pro またはサーバレス SQL ウェアハウスが必要です。 ワークスペースと SQL ウェアハウスにアクセスできる必要があります。

ノートブックが SQL ウェアハウスにアタッチされている場合、ウィジェットの動作は異なります。 詳細については、 「SQL ウェアハウスで Databricks ウィジェットを使用する」を参照してください。

ノートブックを SQLウェアハウスにアタッチするには、以下の手順を実行します。

  1. ノートブックツールバーのコンピュートセレクターをクリックします。ドロップダウンメニューには、現在実行中のリソースまたは最近使用したコンピュートリソースが表示されます。 SQLウェアハウスには SQLウェアハウスラベル.

  2. メニューからSQLウェアハウスを選択します。

    利用可能なすべてのSQLウェアハウスを表示するには、ドロップダウンメニューから「さらに表示…」を選択します。ダイアログが表示され、ノートブックで利用可能なコンピュートリソースが表示されます。「SQLウェアハウス」を選択し、使用するウェアハウスを選択して、「アタッチ」をクリックします。

    SQLウェアハウスが選択された状態の「その他のクラスター」ダイアログ

ワークフローまたはスケジュールされたジョブを作成するときに、SQL ノートブックのコンピュート リソースとして SQL ウェアハウスを選択することもできます。

SQLウェアハウスの制限は以下のとおりです。

  • SQLウェアハウスにアタッチされている場合、実行コンテキストのアイドルタイムアウトは8時間です。

  • 返される結果の最大サイズは、10,000行または2MBのいずれか小さい方です。

ノートブックをデタッチする

コンピュートリソースからノートブックをデタッチするには、ノートブックツールバーのコンピュートセレクターをクリックし、リスト内のアタッチされているクラスターまたはSQLウェアハウスにカーソルを合わせ、サイドメニューを表示します。サイドメニューから「デタッチ」を選択します。

ノートブックをデタッチ

クラスターの詳細ページの「ノートブック」タブを使用して、クラスターからノートブックをデタッチすることもできます。

ノートブックをデタッチすると、実行コンテキストが削除され、計算されたすべての変数値がノートブックからクリアされます。

ヒント

Databricksでは、未使用のノートブックをクラスターからデタッチすることをお勧めしています。これにより、ドライバーのメモリ領域が解放されます。

Web ターミナルと Databricks CLI を使用する

ノートブックで Web ターミナルを開くには、底面パネルを再度開く右サイドバーの下部にあります。

Web ターミナルで Databricks CLI を使用する

Databricks Runtime 15.0 以降では、ノートブックの Web ターミナルから Databricks CLI を使用できるようになりました。

要件

  • ノートブックは、シングル ユーザー モードまたは非分離共有アクセス モードでクラスターに接続する必要があります。

  • CLI は、PrivateLink が有効になっているワークスペースでは使用できません。

インストールされる CLI は常に最新バージョンです。 認証は、現在のユーザーに基づいて行われます。

ノートブック セルから CLI を使用することはできません。 ノートブック内の%sh databricks ...のようなコマンドは、Databricks Runtime 15.0 以降では機能しません。