メインコンテンツまでスキップ

Databricksノートブックセルを整理する

Databricksノートブックは、セルを整理するためのいくつかの方法を提供します。タイトルを追加し、目次を生成し、Markdownの見出しの下にセルを折りたたみ、コードと結果の表示方法を選択できます。

コード セルの書式設定方法については、「 コード セルの書式設定」を参照してください。

ノートブックの目次​

自動的に生成された目次を表示するには、ノートブックの左上 (左側のサイドバーと一番上のセルの間) にあるアイコンをクリックします。 目次は、ノートブックで使用されている Markdown 見出しから生成されます。 タイトル付きのセルは、目次にも表示されます。

TOCを開く

セルのタイトルを追加する​

プロンプト

これを行うように Genie Code に伝えます:

Add descriptive titles for each cell in this notebook.

セルにタイトルを追加するには、次のいずれかの操作を行います。

タイトル付きのセルが ノートブックの目次に表示されます。

セルのタイトルを追加

昇格したセルのタイトル​

UI でセルのタイトルをより見やすくするには、ユーザーは 「昇格されたセルのタイトルを表示する」 をオンにすることができます。

  1. 任意のページの右上で、プロフィール写真をクリックし、[ 設定 ]をクリックします。
  2. [開発者 ] > [ 昇格したセルのタイトルを表示] をクリックします。

セルの内容の表示と非表示​

セルの内容は、セルのコードとセルの実行結果で構成されます。セルコードの表示方法を変更するには、セルの右上にあるケバブメニュー セル ケバブ アイコン をクリックし、 [セルLayout] を選択してから、 [コードをすべて表示] 、 [コードを最小化] 、または [コードを隠す] を選択します。同じサブメニューで、 [結果を表示] を選択して結果を表示または非表示にします。チェックマークは、結果が表示されていることを示します。 セル Layout は、Markdown セルでは使用できません。

非表示のコードを再表示するには、 セルLayout > コードをすべて表示 を選択します。

折りたたみ可能な見出し​

Markdown の見出しを含むセルの後に表示されるセルは、見出しセルに折りたたむことができます。 ノートブック全体で Markdown 見出しを含むセルの後のセルを展開または折りたたむには、[ 表示 ] メニューから [ すべての見出しを折りたたむ ] を選択します。このセクションの残りの部分では、セルのサブセットを展開または折りたたむ方法について説明します。

見出しの展開と折りたたみ​

この画像は、レベル 2 の見出し MLflow セットアップ で、次の 2 つのセルが折りたたまれています。

折りたたまれたセル

見出しを展開および折りたたむには、Markdown セルの上にカーソルを置きます。 セルの左側に表示される矢印をクリックします。

セルの表示オプション​

ノートブックには 3 つの表示オプションがあります。 表示オプションを変更するには、[ 表示 ] メニューを使用します。

  • 標準ビュー:結果がコードセルの直後に表示されます。
  • 結果のみ:結果のみが表示されます。
  • 横に並べて表示:コードと結果のセルが並べて表示されます。

セルの左右にあるアイコンは、使用可能なアクションを示しています。 たとえば、セルの左上にあるグリップ ドットを使用して、セルを セルの移動アイコン上下に移動します。 セルを削除するには、セルの右上にあるごみ箱アイコンを使用します。

編集を容易にするには、フォーカスモードアイコン セルフォーカスアイコン をクリックして、セルを全幅で表示します。 フォーカスモードを終了するには、 セルのフォーカスから出るアイコンをクリックします 。 また、[ 表示] > [中央揃えレイアウト ] をオフにして、セルの表示幅を拡大することもできます。

ノートブック内のすべてのセルを業界標準の行の長さと間隔に自動的に書式設定するには、[ 編集] > [ノートブックの書式設定 ] を選択します。